070. Contare dati univoci senza Pivot

Download PDF

Domanda:

Ricevo ogni mese un numero di bancali che lavorati diventano maggiori. Voglio calcolare per mese quanti bancali ho lavorato. Il problema che i bancali hanno un nome (UDL) che si ripete sugli stessi bancali, es.:
Data Colli Articolo U.M. Qta UDL
23/12/2016 1 122392131018 PZ 1 UDL1700016
23/12/2016 122392131018 PZ 1 UDL1700016
23/12/2016 122392831011 PZ 1 UDL1700016
23/12/2016 122392831011 PZ 1 UDL1700016
28/12/2016 2 02319920 PZ 1 UDL1700004
28/12/2016 02319920 PZ 1 UDL1700004
28/12/2016 21150654 PZ 1 UDL1700004
28/12/2016 02239912 PZ 1 UDL1700004
28/12/2016 02319940 PZ 1 UDL1700002
28/12/2016 03020NLC PZ 1 UDL1700002
28/12/2016 03020NME PZ 1 UDL1700002
28/12/2016 02113192 PZ 1 UDL1700003
28/12/2016 01071087 PZ 1 UDL1700001
quindi ricevuti 3 colli ma in totale sono 5 bancali se leggi gli UDL che si ripetono.
Non riesco a farmi restituire il totale degli UDL = 5

Continua a leggere

069. Aggiungere intervalli ad una data: Date Add in Excel

Download PDF

Domanda:

sto cercando di avere scadenze semestrali in successione su una riga
in K5 inserisco data iniziale
quindi poi in N5 inserisco =SE(VAL.VUOTO(K5);””;SOMMA(K5+180))
tutto ok
quando vado ad inserire in P5 =SE(VAL.VUOTO(N5);””;SOMMA(N5+180))
mi restituisce #valore
praticamente ho capito che il problema sta nel fatto che N5 no risulta vuota ma contiene la formula precedente e quindi mi crea l’errore successivo ma non riesco a trovare la soluzione , è possibile un aiuto?

Continua a leggere

068. Invio mail tramite VBA – risposta a mail ricevuta

Download PDF

A seguito di una domanda che mi è stata posta, ho pensato di creare un tool che una volta ricevuta una mail,
permetta di rispondervi utilizzando dei template.
Il funzionamento è semplice:
1) si apre la mail da Outlook
2) si apre il tool in allegato
3) si seleziona nella colonna A l’argomento del template
4) si preme il tasto ‘Rispondi alla mail
La macro di seguito riportata
– crea una mail di risposta alla mail aperta inserendo tutti gli indirizzi mail coinvolti
– inserisce l’oggetto della mail prendendolo dal file excel
– inserisce il testo della mail prendendolo dal file excel

Continua a leggere

067. Riordinare tabella

Download PDF

Luigi ci scrive:

ho necessita di allineare i dati della colonna A con quelli contenuti nella colonna B traslando i dati della riga relativa
es
Colonna A Colonna B Colonna C
A C 10
B A 20
C D 30
D

RISULTATO
Colonna A Colonna B Colonna C
A A 20
B
C C 10
D D 30
GRAZIE

Continua a leggere